:: Forum >>

Individual cells have links, not the whole column

In my situation, I have individual cells that have links rather than the whole column. In other words, the column may be for URLs, but not all of the cells are filled in. If I set up the whole column to have links, the empty cells will still have a link, but will go to the current page (like a refresh). I would rather show the empty cells not as a link (mouse pointer does not change and clicking does nothing). Any ideas?
Monday, March 14, 2005
possible solution is to return null from your data/link property (not empty string or 'undefined'). null is a special value which removes href (or any other) attribute completely (instead of producing href="")
Alex (ActiveWidgets)
Thursday, March 17, 2005
That seems to work only if the first item is not null. If the first item of that column is null, then it appears to turn off the link completely.
Friday, March 18, 2005
Sorry, my bad. That works great wherever the null is (from my limited testing). I appreciate it. With the empty field though, it still will sort incorrectly . . .

Any chance of helping with this???
Friday, March 18, 2005

This topic is archived.

Back to support forum

Forum search